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Safety and the environment

About this document

-	 Please read this documentation through carefully and familiarize yourself with 
the product before putting it to use. Keep this documentation to hand so 
that you can refer to it when necessary. Hand this documentation on to any 
subsequent users of the product.

-	 Pay particular attention to information emphasized by the following symbols:
	 ·	        With the signal word Caution!:  

Warns against hazards which could result in minor physical injury or damage to 
equipment if the precautionary measures indicated are not taken. 

	       Important.

Avoiding personal injury / damage to equipment

-	� Never store the product together with solvents and do not use any 
desiccants. 

-	� Only operate the product properly, for its intended purpose and within the 
parameters specified in the technical data. Do not use force. 

-	� Only carry out the maintenance and repair work that is described in the 
documentation. Follow the prescribed steps when doing so. Use only OEM 
spare parts from Testo.

Protecting the environment

-	� Send the product back to Testo at the end of its useful life. We will ensure 
that it is disposed of in an environmentally friendly manner. 
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Part 1: testo 6631

Specifications

Functions and use

The testo 6631 is a bio research humidity transmitter for relative humidity 
and temperature. The sensors are located in the housing. The transmitter is 
available with an integrated display for the reading as an option (cannot be 
retrofitted by the customer).

Process security and system availablity, as two of the most important 
parameters in experimental facilities, are supported by a number of properties 
of the testo 6631 bio research transmitter:

• Long-term stability and reliability thanks to the precise Testo humidity sensor

• �Integrated ventilator allows targeted flow impact onto the sensor, making the 
recording of mean climate conditions within greenhouse cells.

• Time savings in commissioning and maintenance due to

– Parameterization, adjustment and analysis software (P2A)

– �Easy and fast ventilator replacement thanks to ventilator drawer assembly 
and plug-in cable

– �Sensor replacement as well as adjustment possibility using saline pots 
through easily accessible service opening

The transmitters must only be assembled, wired and connected by qualified 
personnel. 

The product must not be used in areas at risk of explosion!



Sensor

·	 Humidity: Testo humidity sensor, temperature: NTC
·	 Temperature NTC plug-in

Measuring ranges

·	 Humidity: 0 - 100 % RH (not for high humidity 
process) 

·	 Temperature: -10 - +60 °C/14 - 140 °F

Accuracy

·	 Humidity: ±2.5 % RH (0 - 90 % RH), ±4 % RH  
(> 90 - 100 % RH)

·	 Temperature active : ±0.5 °C/0.9 °F

Reaction time (with protective cap and ventilator running)

·	 Humidity: max. 5 sec (t63% time)
·	 Temperature: max. 20 sec (t63% time)

Analog outputs

	 Humidity: 4...20mA (2 or 4-wire)
·	 Temperature:  4...20mA (2 or 4-wire)
 	 Meas. rate: 1/s

Voltage supply

·	 24 V AC/DC ± 10% AC

Ambient conditions

·	 Operating temperature: -10...+60°C / 14...140°F
·	 Storage temperature: -20...70°C / -4...158°F

Housing

·	 Material: ABS, UV-proof
 	 Colour: white
·	 Dimensions  105 x 139 x 225 mm
· Weight: 1000 g
· Protection class transmitter: IP 65
· Protection class housing: IP 33

Display (optional)

	 2-line LCD

Directives, standards and tests

·	 EC-Diretive: 2014/30/EC
	 EMC DIN EN 61000-6-2 (Immunity) 
·	 DIN EN 61000-6-3 (Emission)

Ventilator

·	 Max. volume flow: 46.80 m3/h / 13 l/s
·	 Life expectancy: 37,500 h (40°C)
·	 Ventilator housing/vane: metal/metal
·	 Bearing system: slide bearing
·	 24 VAC 12 W
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Ordering overview
0555 6631 Bxx / Cxx / Fxx / Gxx / Mxx / Kxx

B01	 4 - 20 mA (2-wire), with separate ventilator supply 
B06	 4 - 20 mA (4-wire), with integrated ventilator supply
C00	 Without display 
C01	 With display
F01	 Relative humidityÿ (% RHÿ
G02	 Temperature (°C)  
G03	 Temperature (°F) 
M01	 Sintered stainless steel filter 
M03	 Sintered PTFE filter 
M05	 Open plastic cap
K01	 Language versions of the instruction manual German-English 
K02	 Language versions of the instruction manual French-English 
K03	 Language versions of the instruction manual Spanish-English 
K04	 Language versions of the instruction manual Italian-English 
K05	 Language versions of the instruction manual Dutch-English 
K06	 Language versions of the instruction manual Japanese-English 
K07	 Language versions of the instruction manual Chinese-English

Sample orders testo 6631

··	4...20 mA (2-wire), with display, %rF/°C,  Bedienungsanleitung Deutsch-Englisch: 
0555 6631 / B01 / C01 / F01 / G02 / M05 / K01

Technical data
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Dimensions
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Product description

At a glance:
1	� Suspension ring
2	 Voltage supply / signal output
3	� Ventilator
4	 �Ventilator drawer assembly (rear)
5	� Service opening for humidity sensor 

(rear)
6	��� Mini-DIN-connection for P2A 

software and 1-point  adjustment
7	 Two line display
8	 �Ventilation shaft
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Commissioning

Connecting instrument
ã	Replacing ventilator: 

1.	��Connect plug-in cable.

2.	� Place ventilator drawer assembly 
into housing.

3.	� Tighten screw on ventilator drawer 
assembly.

ã	Install instrument in a suitable position:

1	 Connect the supply line to the socket plug on the instrument.
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Electrical connection
2-wire technology 
									         ·	Plug manufacturer: Euchner

·	Cable socket (not included in delivery): Type BS 7K 
·	Pin socket (fitted in instrument ex-works): Type SD 7K

							       1	 %RH (4...20mA)	
							       2	 °C/°F (4...20mA)
							       3	 AC ventilator
							       4	 Not in use
							       5	 Top view of plug socket

  DC: Supply transmitter
  AC: Supply ventilator 

4-wire technology 
									        ·	 Plug manufacturer: Firma Tuchel-Amphenol

·	Cable socket (not included in delivery): 
  Type 01630D00610010
·	Pin socket (fitted in instrument ex-works): Type Eco 
  mate instrument plug

							       1	 %RH (4...20mA)
							       2	 °C/°F (4...20mA)
							       3	 AC ventilator and transmitter
							       4	 Top view of plug socket

  AC: Supply transmitter and ventilator
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Parameterizing/adjusting/analyzing the 
instrument
	 The analog outputs can be scaled in the following ranges, beyond the 

measurement range of the measurement transmitter: -50…100°C / -58…
212°F, -50…150%RH.

	 	�Scaling beyond the measurement range allows the adaptation of the scaling 
limits to prescribed values from a PLC. The measurement range itself cannot 
be extended this way.

The instrument is parameterized, adjusted and analyzed using the P2A 
Software, see “Part 2: testo P2A Software”.
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Maintaining the product
				    Caution! 

Never put your hands inside housing openings when the ventilator is running. 
This could lead to injury. Disconnect the instrument from the mains supply 
before cleaning or exchanging the ventilator, and wait until the ventilator has 
come to a standstill. 

â	Cleaning the housing:

	 Clean the housing with a damp cloth (soap suds) if it is dirty. Do not use 
aggressive cleaning agents or solvents!

	 Check the grille on the underside of the instrument every three months, 
and if dirty, clean with a damp cloth (soap solution). Do not use 
aggressive cleaning materials or solvents!

â	Cleaning the sensor 

�	 	�During cleaning, avoid touching the sensor at all costs.

						      1. Remove service opening.

						      2. Unscrew sensor protection 		
						       cap.

						      3. �Carefully rinse the mirrored surface 
with isopropyl alcohol and/or distilled 
water. 

						      4. Allow the sensor to dry 			
						       completely.

						      5	 Unscrew sensor protection 		
						       cover.

						      6. Close service opening.
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â	Exchanging sensor 

1.	�Loosen screw on the ventilator 
drawer assembly.

2.	� Remove drawer assembly with the 
ventilator from the housing.

3.	� Disconnect plug-in cable.

4.	� Remove ventilator from drawer 
assembly using Allen key.

5.	� Fix new ventilator into drawer 
assembly using Allen key.

6.	� Connect plug-in cable.

7.	� Place drawer assembly with 
ventilator into housing.

8.	�� Tighten screw on ventilator drawer 
assembly.
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Tips and assistance

Questions and answers

If you had any question, please contact your dealer or Testo Customer Service. 
For contact data, see back of this document or web page www.testo.com/
service-contact. 

Accessories and spare parts
Designation	 Article no.

Parameterizing, adjusting and analyzing software (P2A Software incl. adapter cable for USB to mini-DIN)	 0554 6020
Process display testo 54-2 AC, two relay outputs (to 250 VAC/300 VAC, 3 A),  
mains power supply 90...260 VAC	 5400 7553 
Process display testo 54-7 AC, two relay outputs  (to 250 VAC/300 VAC, 3 A),  
mains power supply 90...260 VAC, with RS485-output for Online Monitoring and with toatlizer display	5400 7555
Humidity adjustment set(11.3% and 75.3%RH) 	 0554 0660
ISO calibration certificate humidity at 11.3% and 75.3%RH	 0520 0076

For a complete list of all accessories and spare parts, please refer to the 
product catalogues and brochures or look up our website at: www.testo.com
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Part 2: testo P2A Software

Specifications
The P2A software is used for the parameterization, adjustment and analysis of 
Testo transmitters. The following applies:

•	 If a Testo transmitter is bought at a later stage (and is therefore more recent 	
	 than the existing P2A software version), a software update is required.

•	 You can find the free upgrade on the Testo website www.testo.com under 	
	 the product-specific downloads.

•	 The software therefore only needs to be bought once, even for owners of 	
	 several Testo transmitters.

System requirements 

Operating system

 Windows® 7, Windows® 8 oder Windows® 10 

Computer

The computer must meet the requirements of the operating system in each 
case. The following requirements must also be met:  

•	 USB 1.1 interface or higher

•	 Graphics resolution of at least 1024 x 768

•	 Date and time settings are automatically adopted by the PC. The 
administrator must make sure that the system time is regularly compared 
with a reliable time source, and adjusted if necessary, in order to ensure the 
authenticity of the data
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First steps
Installing the software / driver
	 Administrator rights are required for the installation of the testo P2A 

Software.

â	Installing the P2A Software:

    Without the input of a licence key, the software will run only as a demo 
version (time limit 30 days).

1.	You can download the software under the following link:  
https://www.testo.com/download-center

 	 If the installation program does not start automatically: > Open download 
folder and start P2A.exe.

2.	Follow the instructions of the installation wizard. 

3.	Click on [Finish] to complete the software installation. 

â	Installing the USB drivers:

1.	You can download the USB driver under the following link: 
https://www.testo.com/download-center (Testo USB driver)

	 If the installation program does not start automatically: > Open download 
folder and start USBDriver.exe

2.	Follow the instructions of the installation wizard. 

3.	Click on [Finish] to complete the software installation. 

â	P2A Software update:

P2A software update

1.	You can find the P2A software upgrade on the Testo website www.testo.
com under the product-specific downloads. Download and save P2A 
software upgrade.

2.	Start P2A upgrade.exe file.

3.	Follow the instructions of the installation wizard.
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Starting the software
Starting the program:

Windows program menu

Windows® 7

>	 Click on [Start] > All Programs > Testo > P2A Software (double-click on 
left mouse button).

Windows® 8 

>	 Click on [Start] | right mouse button | Search | Enter the name of the 
application in the search field | P2A Software.  (double-click on left mouse 
button).

Windows® 10 
>	 Click on [Start] | All Apps | Testo | P2A Software.  (double-click on left 

mouse button).
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Product description

User interface

	
1	 Menu bar.
2	 Toolbar.
3	 File list: List of all instrument/parameter files.

File symbols

·	 : Instrument file, connection to the unit has not been established.

·	 : �Instrument file, connection to instrument is established.„[Type] [Serial number].cfm“, File names cannot 
be altered. Instrument files contain all data on a certain intrument. These are the parameter data and 
parameterization and adjustment history of the instrument

·	 : �Parameter file. „[Type] [Serial number] [Date] [Time].cfp“, File names can be altered. ·Parameter files 
contain only parameter data. These can be copied into another instrument or paramerter file of the same 
instrument type, so that several instruments have the same parameter settings. The name is freely 
selectable, however it is recommended that the instrument context is retained. Parameter files are always 
marked in red, the parameter values contained in them are only passed on to the instrument after transfer 
to the instrument file.

4	 List of functions.
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5	 Instrument information: 

Information displayed

·	 Instrument files: Type, serial number, firmware version and connection status of the instrument.
·	 Parameter file: Type, serial number and firmware version of instrument with which the parameter file was 

created.
·	 Connection status (instrument files only): “green” connection is active, “red” connection is inactive.
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Using the product

â	Establishing a connection with the device:

Several instruments can be connected to the PC and administered via the 
P2A software, but only one connection can ever be active at any one time. 

Non-wired instruments can also be connected to the P2A Software for 
parameterization/adjustment. The supply to the instruments is then effected 
via the USB interface (analog outputs not functional).

1	 Connect the USB/mini-DIN adapter to the external interface (mini-DIN) of 
the instrument.

2	 Connect the USB connector of the adapter to the PC.
-	 The instrument file for the instrument connected appears in the 

instrument file/parameter file list. 

â	Selecting the instrument/parameter file, activating a connection with the 
device:

	 Click on the requisite instrument/parameter file. 
-	 The selected file is highlighted in colour.

-	 For instrument files only: if a connection with the instrument has been 
established, this is automatically activated. 

â	Changing an instrument/parameter file:

3	 The required instrument/parameter file is selected.

1	 Click on Change parameterization button.

2	 Select channel.

3	 Enter parameters in the corresponding fields.

Unit / Analog output (Graph)

·	 Unit: 0…1V / 5V / 10V or 0...20 mA / 4…20 mA. Vertical: Current version of the analog output (not alterable). 
Horizontal: Min/max. Scale end points of the selected unit. The curve shifts according to the value entered at 
Scale minimum or maximum.

Scale minimum/maximum

·	 The end points of the scaling can be selected up to the stored scale minimum and maximum. In order to 
adapt the analog output to the customer’s system, it is possible to scale beyond the end of the measuring 
range.

Unit

·	 Selection of the physical unit. When the unit is changed, standard values are set at Scale minimum and 
maximum. Attention! Changes to the physical unit cause the relay limit values to be set to the allocated 
default values.

4	 Click on Apply to confirm entries.
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5	 To leave the parameterization screen, click on OK.

â	Saving the parameters in a parameter file:

Parameters can be stored in new parameter files.

3	 The required instrument/parameter file is selected.

1	 In the menu bar, click on File > Save as.

2	 Select the storage location and enter the file name.

3	 Click on Save to confirm entries.
The new parameter file is stored in the file list 
�	 Only the parameters from an instrument file are stored, the history data 

are not transferred.
�	 As standard, the original name (instrument type, serial number) with the 

current date / time is suggested, e. g.. „testo 6631 01234578 061120 
1403.cfp“. In a standard installation, the files are stored in the path „C:\
Documents and Settings\All Users\Common Documents\P2A Software“. 
However, the path can differ depending on the operating system version.

â	Opening a parameter file:

All parameter files stored in the standard directory path are automatically 
displayed in the file list when the software is started. Parameter files stored in 
other directories can also be opened.

	 Only parameter data stored in the standard file can be loaded into an 
instrument! 

1	 In the menu bar, click on File > Open.

2	 Select the storage location and click on the requisite parameter file.

3	 Click on Open to confirm entries.

â	Copying the parameter data:

The parameter data for an instrument/parameter file can be transferred to 
another instrument/parameter file for the same type of instrument. History 
data for instrument files are not transferred. 

1	 Select file from which the parameter data are to be copied.

2	 In the menu bar, click on Edit > Copy. 

3	 Select the file which is to be modified.

4	 In the menu bar, click on Edit > Paste.
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â	Analyzing/testing the instrument:

3	 The required instrument file is selected.

1	 Click on Test / analyze transmitter button.

2	 Perform tasks:

Options

·	 Carry out factory reset: Reset the parameter unit, scaling limits and adjustment to the factory settings 
(Values instrument-specific, see specification plate).

·	 Transmitter tests (voltage supply via terminals required): Current reading displayed and analog output test 
carried out for each channel; see below for procedure.

·	 Min./max. values: Change to display of minimum/maximum values.

Procedure: testing analog output (voltage supply via terminals required)

1	Choose channel.
2	Connect reference multimeter (min. 6.5 digits resolution) to the analog output terminals of the transmitter.
3	Set the default value in the P2A Software and click on Activate.
4	Compare value displayed with reference value of multimeter.

3	 To leave the analyzing/test screen, click on OK.

â	Carrying out/resetting a 1-point adjustment (offset):

1	 Click on Adjust transmitter button.

2	 Select the channel under 1-point adjustment.

3	 Expose the reference measuring instrument and the instrument to be 
adjusted to the same constant conditions and wait for equalization period 
to lapse.

4	 Enter reference value and perform adjustment by clicking on Carry out 
1-point adjustment.

	 To reset an offset value, click on Set Offset to zero.

5	 Click on OK  to confirm entries.

â	Carrying out a 2-point adjustment:

	 Before the 2-point adjustment, it must be ensured that the ventilator of the 
testo 6631 is operating, and that the air input opening is not blocked.

1	 Click on Adjust transmitter button.

2	 Select the adjustment point under 2-point adjustment.

3	 To set the humidity generator: Temperature of 25 °C and humidity of 
11.3 % RH or 75.3 % RH (depending on adjustment point chosen).

4	 After a sufficient equalization period (at least 1.5 h): Enter reference value 
and perform adjustment by clicking on Lower adjustment point or Upper 
adjustment point (depending on adjustment point chosen).

5	 Repeat steps 3 to 4 for the second adjustment point accordingly.
6	 Click on OK  to confirm entries.
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	 For the testo 6631, a 2-point adjustment can also be performed using 
the testo control and adjustment set (0554 0660). Please also refer to 
the instruction manual for the control and adjustment set. The reference 
values are entered and the adjustment is carried out in the same way as 
for an adjustment with a humidity generator/air conditioning cabinet (see 
steps 1 to 6).

â	Carrying out an analog adjustment:
	 Voltage supply via terminals required.
1	 Click on Adjust transmitter button.

2	 Choose channel.

3	 Connect reference multimeter (min. 6.5 digits resolution) to the analog 
output terminals of the transmitter.

4	 Click on Start Wizard... button and follow the instructions issued by the P2A 
Software.

5	 Click on OK  to confirm entries.

â	Viewing a transmitter history:

The current history data are always displayed as stored in the instrument file. 
A distinction is made between parameterization and adjustment histories.

	 Dates and times refer to the PC time when the P2A Software was being 
used.  
History data are only stored in the instrument file (PC), not in the 
testo 6631.

1	 Click on Transmitter history button.

2	 To move between the views, click on Parameterization history or Adjustment 
history.

	 To print the history data, click on Print.
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â	Deleting parameters from an instrument/parameter file:

The parameter data for the selected instrument/parameter file can be 
deleted.

3	 The required instrument/parameter file is selected.

1	 Right-click on the instrument/parameter file.

2	 Select Delete.

3	 Click on Yes to confirm.

â	Creating a new folder:

3	 The folder to which the new folder is to be added is selected.

1	 In the menu bar, click on File > Add Folder.

2	 Give the new folder a name.

testo P2A Software - Using the product
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Tips and assistance

Questions and answers
Question	 Possible causes/solutions

Connection to instrument cannot  
be established.	 ·	 Check connecting cable and plug contacts. 
		  ·	 USB driver not/incorrectly installed: Re-install.
Adjustment is to be reversed.	 ·	� Carry out factory reset: Click on Test / analyze transmitter > 

Click on Carry out factory reset.

If we could not answer your question, please contact your dealer or Testo 
Customer Service. For contact data, see back of this document or web page 
www.testo.com/service-contact 

testo P2A Software - Tips and assistance
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